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This handout explains how to create an external style sheet, the purpose of 
selector types and how to create styles. It does not show how to insert div 
tags.  
 
What follows is the implementation of an external style sheet and how to 
create styles with the various style selectors. After practicing the styles, try 
experimenting with creating styles for other elements on the page.  
 

 
                         CSS Styles panel – Window > CSS Styles 

 
Creating and linking a style sheet to an HTML document 
Firstly, establish a root folder and define the site in DW with the Manage Sites 
procedure. Then create the required site structure and HTML files via the 
Files window.  
 
It is best practice to save css files into a folder called css in the root folder. 
 
A new CSS file can be created by: 

• Go to File > New… and in the New Document window choose Blank 
Page – CSS and click on create. A new CSS document appears in the 
work space.  
 
Next, save the file. Go to File > Save or Save As. Ensure that the file is 
saved with the .css file extention 

• Create a new file in the Files panel as if creating a new HTML 
document. Give the file a name and ensure that the file is named with 
the .css file extention 

 



When naming a style sheet, use the same naming principles as when naming 
an html document e.g. lower case, no spaces etc. 

 
Linking the style sheet 
Styles in the CSS document will have no impact upon a web page unless that 
web page is linked (attached) to it. To attach a CCS document, ensure the 
web page is the active document on the DW work space.  
 
In the CSS window, click on the Attach Style Sheet button and the Attach 
External Style Sheet dialogue opens.  
 

 
 
Browse for the style sheet, for Add as: choose link. From the Media drop 
down select screen. Click OK. Screen defines the CSS document as one that 
is for presentation of the web page in a browser. 
 
A link to the style sheet is now entered into the head of the HTML document: 
 
<link href="css/intro.css" rel="stylesheet" type="text/css" media="screen"> 
 

A reference to the style sheet will now be visible in the CSS Styles panel. 
 
 

 
 
Getting ready to use the style sheet 
If the HTML document is blank then it will need to be populated with content. 
Typically, content would be added prior to creating styles and styles created 
as you go along. 
 
The styling of elements can be created from the Properties panel or from the 
CSS panel. In either case it is essential that styles are entered into the 
external style sheet and not in the head of the HTML document.  For the 
purposes of simplicity, the process described here creates styles from the 
CSS panel only.  
Creating and applying styles 
There are three main types of styles called selectors that can be created: 
 



1. Class Selector. These are styles that can be applied to any element or 
item selected in the web page. These are the selector types that are 
created when using the Properties panel to change the appearance of 
selected text. A particular class selector can be used more than once 
on a web page. 
 

2. Tag Selector. These target HTML tags in the web page. A style 
created for a tag affects every instance of that tag on the page.  

 
3. ID Selector. ID is short-hand for identifier. These are commonly used 

for positioning <div> tags in page layout. An ID selector should only be 
used once in a page. 

 
Class and ID selectors are essentially the same – there is no difference in 
what can be done with them. The difference between them is semantic (the 
meaning) that is; Class selectors can be used more than once in a web page 
and ID selectors should be used only once in a web page. 
 
Compound Selector 
A type of hybrid selector is a Compound selector. This is a style made from a 
combination of one or more of the three main selectors. They offer increased 
flexibility in styling elements on a page. For instance, if an <h2> tag appears 
more than once on a page, using an h2 tag selector will make all instances of 
<h2> look the same. But, if different styles are required for them, then a 
compound selector can be created to make one instance of <h2> look 
different to any others. 
 
Note: In general, any styling properties not required when creating styles do 
not need to be specified. Only supply properties for those that are required. 
 
Naming styles 
For the naming of styles names the following should be observed: 

• No spaces in names – underscore can be used (_) to denote spaces 
• Use only letters and numbers 
• Upper and lowercase can be used 

 
Certain characters are used to denote particular selectors e.g.  

• The full stop (.) denotes a class selector 
• The hash sign (#) denotes an ID selector 
• Tag selectors use the name of the HTML tag they are selecting 

and do not use a prefix. 
 
The ID selector 
The purpose of creating an ID for an element on a page is to make a 
statement about it, as well as being able to change the appearance of that 
element. An HTML element can be given an ID name. This would appear in 
the code like this:: 
 
<div id=”banner”> 
 
An ID is just like giving the HTML element a label. This in itself would not do 
anything to the HTML element until a style is created that uses that ID name. 



 
When using div tags to control the layout of a page, each div will often have a 
unique position on that page. Therefore, it would be appropriate to use IDs for 
them. 
 
- What follows can be used in conjunction with the Intro to CSS exercise - 
 
In the Design view, place the cursor in the placeholder text for a div tag. Click 
on New CSS Rule in the CSS Styles panel. The New CSS Rule dialogue 
opens: 
 

 
 
The Selector Name field should contain the ID name given to the div when it 
was inserted into the page. If it does not, then type in the name (including the 
hash sign). Ensure that the Rule Definition names your style sheet. Click OK. 
 
The CSS Rule Definition dialogue opens. This looks much like the Page 
Properties but there are many more options here. All styles are created from 
this dialogue. 
 
In Category, on the left, choose Box. And enter the properties as in the 
following illustration and Click OK. 
 



 
 
Margin auto for right and left positions the div in the horizontal centre of the 
page. 
 
The Tag Selector 
Typically, the first styles created (after those made for the size and position of 
div tags) are for the default text style and background colour. These attributes 
can be applied via the <body> tag.  
 
In the CSS Styles panel click on the New CSS Rule button. This opens the 
New CSS Rule window. From here, under Selector Type, choose Tag from 
the drop-down list. Next, under Selector Name, click on the dropdown list and 
choose the appropriate tag, in this case choose body. 
 

 
 
Ensure that your style sheet is referenced where it says Rule Definition.  
Click OK. 
 
Note: It is also possible to define the style in the HTML document from the 
Rule Definition drop-down and choosing “This document only”. This will create 



the style in the head of the document. This can be used to override styles 
created in the external style sheet. This is a feature of the ‘cascade’. Do not 
do this at this stage. 
 

 
 
Select the Background category and choose properties for background colour 
and background image. For a background image (supplied with the exercise) 
click Browse for the image and choose:  
 

Background-position (for x and y): centre 
 
Click on Apply and the style will be applied to the page. Next, go to the Box 
category to set the page margins. This will position the contents of the page in 
relation to the edges of the browser window e.g. 
 

 
 
Click OK when finished. 
 
The style will now be referenced in the CSS Styles window beneath the name 
of the style sheet. 
 
Editing a style 
Dreamweaver provides several ways to edit a style sheet. Which method you 
choose depends on what is convenient to the way you work. To change the 
properties of a style do one of these 4 methods (the easiest options are the 
first two): 
 



• In the CSS Styles panel double click on the style name or select the 
style name and click on the Edit Style button. This will open the CSS 
Rule Definition dialogue. Avoid clicking on the New CSS Rule button as 
this will create a duplicate style and lead to confusion. 

 
• Alternatively, elements for the style can be edited quickly from the 

properties section at the bottom of the panel. Click in the right hand 
column for existing properties and enter new values as required.  

 

 
 

• A reference to the style sheet also appears at the top of the document 
window for any web page that is linked to a style sheet. This is the area 
where Related Files to the HTML document appear. 

 

 
 

In Split view, click on the reference to the CSS file and it will appear in 
split view along with the design view of the html page. It is possible to 
edit the style sheet by typing into the style sheet directly. For any 
changes made this way to be visible in the web page, the design view 
will need to be refreshed. Do this by clicking in the design view or 
pressing F5. 
 

• Open the CSS file as a separate document in the workspace. To open 
the CSS, double click on the file in the Files panel. Edit the CSS by 
typing into the style sheet directly. For any changes made this way to 
be visible in the web page, the design view will need to be refreshed. 
Do this by clicking in the design view or pressing F5. 

 



Previewing in a browser 
Previewing in a browser may now require saving two documents. Changes 
made in the style sheet will not appear in the page when viewed in a browser 
if the style sheet has not been saved, even though the web page itself may be 
saved. When going to Preview in Browser, DW will prompt you to save 
changed documents.  
 
Note: You can see if a document has unsaved changes because an asterisk 
(*) appears by the filename in tabs and related files at the top of the document 
window. 
 
Heading sizes 
Styles can be created for each heading size used on the page. To do this, 
proceed as with the body style, choosing Tag as Selector Type and the 
relevant heading size from Selector Name the drop down list.  
 
Note: You can also place the cursor within the heading before choosing New 
CSS Rule. This can make DW assume that a Compound Selector is required 
e.g. 
 

 
 

To remove references other than the heading size either click on the Less 
Specific button or delete them from the Selector Name field. Compound 
selectors are explained later. 
 
Text links 
Text links can be styled to appear differently to what is dictated by browser 
default. Dreamweaver places access for these under the Compound category 
in the New CSS dialogue. Text link styles are a type of selector referred to as 
pseudo-classes. Pseudo-classes allow special effects to be added to 
selectors.  
 
Go to: http://www.w3schools.com/CSS/css_pseudo_classes.asp for more information 
 



 
There are four categories available for styling text links: 

a:link = how the link first appears 
a:visited = appearance after the link has been clicked 
a:hover = appearance when the cursor is over the link 
a:active = appearance on mouse down and when the link is active e.g. 
open in another window 
 

Before styling to take effect, the menu text on the page will need to have links 
applied to them. To style text links there is no need to select them first. As 
before, click on New CSS Rule in the CSS Styles panel. Under Selector type 
choose Compound then click on the drop-down for Selector name to see the 
link styles. 
 
Best advice is to create a style for each category to override browser default 
values. Also, ensure they are created in the style sheet in the order they are 
presented in the drop-down list, otherwise they may not work effectively. Only 
the style for a:link will be visible in DW. Preview in a browser to see the full 
effect. 
 

 
 
Note: The browser will retain a memory of any links that have been clicked. 
Therefore, when previewing text links in a browser, the style for visited links 
may be visible and not the primary a:link style. To undo this in the browser, 
clear the history and click on the refresh button or press the F5 key. 
 
The Class selector 
Class selectors can be used more than once in a page if required. Use class 
selectors for elements on the page that may require the same properties. 
Elements that may be suitable for styling with class selectors are text and 
images.  
 
Let us presume that there is a particular word or phrase within the text that 
requires a different look to the main body of text. Emphasis can be done via 
HTML tags such as italics <em> or bold <strong> etc. and of course styles 
can then be created for those tags to modify their appearance by using a tag 
selector.  



 
But, what if we want to retain those tags for other uses but require a different 
appearance for the text, such as a different font and colour? This can be done 
by creating a Class Selector and applying it to the text on the page. 
 
To create the style, proceed as before when making a new CSS rule (it is not 
necessary to have anything selected in the web page first). This time choose 
Class as the Selector Type. A name for this style will need to be created. 
Enter this in the Selector Name field. There is no need to prefix the name with 
a full stop as choosing the Selector Type as Class will do this automatically. 
Give the style a meaningful name, bearing in mind that there may eventually 
be more than one class selector created for text. Something such as text_1 or 
text_2 would be appropriate. 
 
Click OK and give the style properties as required. This time, clicking on apply 
does not work. This is because the style is not yet applied to the item on the 
page. This will need to be done after. 
 
Applying a class selector 
Click OK and the style will be present in the CSS window. Select a word, or 
words, within the text in the page or place the cursor within a paragraph. Then 
do one of the following: 
 

• In the CSS window, highlight the style to be applied and from the CSS 
Styles menu choose Apply. 

 

 
 
 

• Right click or Cmd click (Mac) on the style in the CSS window and 
choose Apply 

• In the Properties panel click on the Style drop down menu and choose 
the style from this list. Any class selectors you create will be available 
from the Properties panel in either HTML or CSS view. 

 
In the code the style will be applied via a <span> tag like this: 
 
<span class="text_1">original HTML</span> 
 
DW places the <span> tag around the text selected on the page and includes 
the class style as an attribute of that tag. 



If a paragraph is selected then the code will look like this: 
 
<p class="text_1">The text in a paragraph</p> 
 
DW includes the style as an attribute of the <p> tag. 
 
To apply the style to more text on the page, select the text as before and in 
the CSS Styles panel: 
 

• Right click on the style name and choose Apply 
• Cmd click (Mac) on the style name and choose Apply 
• Select the style name in the CSS Styles panel and choose Apply from 

the panel menu. 
  

Image margins and alignment 
Create space (margin) around an image and align it with adjacent text. To do 
this, proceed as before to create a class selector and call it something like 
image_1. Go to the Box category, enter values for Margin and choose left for 
Float.  
 

 
 
To apply the style to the image, select the image on the page and apply as 
described under applying a class selector.  
 
The Float property aligns the image to the left of other elements for instance, 
text. This property is often used for aligning div tags horizontally next to each 
other. 
 
The Compound selector 
In the Introduction to CSS exercise, a heading size (<h1> or <h2>) is used in 
both the header and content divs. It is possible to make one of these heading 
sizes look different by using a compound selector.  
 
In the content div, place the cursor within the heading. Create a New CSS 
Rule as before. The New CSS Rule window appears with compound as the 
Selector Type and the Selector Name written as #content h1 or #content h2.  



If there are more references than this in the New CSS Rule dialogue, then 
click on the Less Specific button or delete them from the Selector Name field. 
 

 
 
Click OK and style the heading as required.  
 
This will also affect any other headings of that size in the content div but not 
that heading anywhere else on the page. Changing the appearance of the 
size of a heading on the page does not impact upon the importance of the 
heading as defined by the HTML.  
 
Editing styles with the Properties panel 
Class selectors can also be quickly edited from the Properties panel. Select 
the item on the page by highlighting or placing the cursor within it. In CSS 
view, the style name should appear in the Targeted Rule field. 
 

 
 
Change the properties for the style from the available text options or click on 
the Edit Rule button. 
 
Avoid this 
The next illustration shows the CSS Styles panel, which includes an entry for 
another style sheet. This denotes that a style sheet has been established in 
the <head> of the HTML document. Avoid doing this at this stage, as it will 
make things confusing. 
 



 
 
This technique will be used later after completion of the web site, to illustrate 
the effect of the cascade in CSS. 
 
Creating the other pages 
After completion of the first page go to File > Save As and save the page as 
the next page in the web site. This will entail replacing one of the blank HTML 
documents created as part of the Manage Sites process. This page will now 
have content from the first page along with the link to the style sheet and page 
styling.  
 
Change the content of the page, such as title, headings and text to reflect the 
subject of the new page. Styles created for tags, text links, identifiers and 
compound selectors will still be apparent unless elements on the page have 
been removed or changed somehow. You will find it necessary to re-apply 
class selectors to the page, for instance where text has been changed. 
 
The Cascade 
Let us suppose you require one of your pages to have a different background 
to the others. This can be achieved by creating a body style in the head of 
that HTML document. Make the HTML document to be changed the active 
document in the work space. Proceed as when first creating the body style but 
this time choose to define it in This document only in the CSS Rule dialogue. 
Click OK 
 



 
 
Select a different background colour and click OK.  
 
This will override the background colour created for the body style in the 
external style sheet but the background image will still be present. 
 
This illustrates one way of employing the cascade in CSS. If a style with the 
same name is defined in an external style sheet and in the <head> of a web 
page, any values for properties defined for the style in the <head> will 
override the corresponding properties in the external style sheet.  
 
Properties that are not defined in the <head> will allow those in the external 
style sheet to flow or cascade through. This is why the background image still 
appears on the page. 
 
 
 
 
 


